Cisco

Switch Cisco – Configuration Spanning Tree

Le standard 802.1D est la formalisation du protocole STP (Spanning Tree Protocol) qui est un protocole de couche 2 du modèle OSI. Le STP est utilisé dans un réseau ayant des liens physiques redondants, dans le but d’empêcher la création de boucles réseaux.  Le spanning tree cisco est une variante du STP : Per-VLAN Spanning-Tree. Il permet de configurer une topologie de Spanning-Tree par VLAN.


À Savoir

Le protocole Per-VLAN Spanning-Tree (PVST) est activé par défaut sur les switches Cisco.

Mise en route

Activer le Rapid PVST

Le spanning tree cisco « classique » demande jusqu’à 50 secondes pour définir une topologie de spanning-tree après un changement sur le réseau (comme la panne du root bridge), là où le Rapid PVST (RPVST) nécessite seulement 6 secondes.

Configurer

Activer le RPVST :

cisco(config) #spanning-tree mode rapid-pvst

Vérification

Afficher un résumé de la configuration du spanning-tree :

cisco#show spanning-tree summary

POD_01#show spanning-tree summary
Switch is in rapid-pvst mode   # Activation du RPVST ok
Root bridge for: VLAN0001
Extended system ID           is enabled
Portfast Default             is disabled

Élire le Root Bridge

Un switch est élu RT selon sa Bridge Priority : celui ayant la priorité la plus base est élu.

Par défaut, la valeur de la priorité est 32 768.

Configurer

Élire manuellement le RT :

cisco(config) # spanning-tree vlan vlan_id root primary

Cette commande diminue la priorité à 24 576 + numéro du VLAN.

Pour configurer un pool de VLANs renseignez le premier et dernier VLAN du pool de la manière suivante :

spanning-tree vlan 1-10 root primary

[ Facultatif ] Désigner un RT secondaire :

cisco(config) # spanning-tree vlan vlan_id root secondary

Cette commande diminue la priorité à 28 672 + numéro du VLAN.

Si le RT primaire devient inaccessible, le secondaire sera automatiquement élu car sa priorité est plus basse que celle des autres switches (qui est à 32 768).

Exemple

Sur le RT primaire :

POD_01#configure terminal
Entrez les commandes de configuration, une par ligne. Terminez avec CNTL / Z.
POD_01(config)#spanning-tree vlan 1 root primary
POD_01(config)#end
POD_01#

Sur le RT secondaire :

POD_02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
POD_02(config)#spanning-tree vlan 1 root secondary
POD_02(config)#end

Vérification

Afficher le RT pour chaque VLAN :

cisco#show spanning-tree root

L’exemple ci-dessous montre résultat de la commande depuis un switch lambda :

POD_03#show spanning-tree root
                                        Root    Hello Max Fwd
Vlan                   Root ID          Cost    Time  Age Dly  Root Port
---------------- -------------------- --------- ----- --- ---  ------------
VLAN0001         24577 0016.46b7.d380        19    2   20  15  Fa0/24   # Root bridge ok (0016.46b7.d380 = @MAC de POD_01)

Pour tester le secondaire, il vous suffit d’éteindre ou de sortir du réseau le  switche RT primaire et de contrôler que le switch secondaire soit élu RT.

Configuration Spanning Tree

Les différentes configurations que nous allons voir ci-dessous ne sont pas obligatoirement que le fonctionnement du spanning-tree, mais elles peuvent vous être utile selon votre situation.

Modifier la priorité d’un port

Configurer

Quand 2 chemins ont le même coût, ils sont départagés en fonction de la priorité du port par lequel chacun passe : celui ayant la priorité la plus faible l’emporte.

En modifiant ce paramètre vous pouvez privilégier un chemin par rapport à un autre, selon vos besoins. Par défaut, la priorité d’un port est 128 et les ports sont départagés en fonction de leur numéro de port.

Configurer la priorité d’un port :

cisco(config-if)#spanning-tree port-priority priorité_du_port

La priorité doit être comprise entre 1 et 240 et être un multiple de 16.

Exemple

POD_03#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
POD_03(config)#interface fastEthernet 0/24
POD_03(config-if)#spanning-tree port-priority 32
POD_03(config-if)#end

Vérification

Afficher la configuration du spanning-tree sur une interface :

cisco#show spanning-tree interface type_interface numéro_interface

POD_03#show spanning-tree interface fastEthernet 0/24
Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Root FWD 19         32.24   P2p Peer(STP)   # Priorité du port OK

Modifier le coût d’un port

Configurer

Le coût d’une interface intervient dans le calcul du chemin le plus rapide pour atteindre le RT. En modifiant ce paramètre vous pouvez forcer le choix d’un chemin, même si celui-ci est plus coûteux qu’un autre.

Voici le tableau des coûts en fonction de la vitesse de l’interface :

Vitesse
Coût
10 Mbps
100
100 Mbps
19
1-Gigabit Ethernet
4
10-Gigabit Ethernet
2

Modifier le coût d’une interface pour tous les VLANs :

cisco(config-if)#spanning-tree cost coût

Modifier le coût pour un VLAN spécifique :

cisco(config-if)#spanning-tree vlan vlan_id cost

Le coût doit être compris entre 1 et 200000000.

Exemple

cisco#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
cisco(config)#interface fastEthernet 1/2
cisco(config-if)#spanning-tree cost 2
cisco(config-if)#end

Vérification

Afficher un résumé des interfaces sur lesquels est activé le STP :

cisco#show spanning-tree brief

VLAN1
  Spanning tree enabled protocol ieee
  Root ID    Priority    16384
             Address     c401.1a00.0000
             Cost        40
             Port        43 (FastEthernet1/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32768
             Address     c405.1a84.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/1      128.42   128    19 BLK    38 32768 c404.1ba8.0000 128.43
FastEthernet1/2      128.43   128     2 FWD    38 32768 c402.1740.0000 128.43  # Configuration du coût ok

Le coût de l’interface FastEthernet1/2 étant plus faible, elle a été choisie pour le chemin vers le RT.

Modifier la priorité d’un switch

Configurer

Il est recommandé d’utiliser les commandes vues en Élire le Root Bridge pour modifier la priorité d’un switch automatiquement. Néanmoins, il est bon de savoir modifier manuellement cette priorité.

Modifier la bridge priority :

cisco(config)#spanning-tree vlan vlan_id priority priorité

La priorité doit être comprise entre 1 et 65 534 et être un multiple de 4096.

Exemple

POD_01#configure terminal
POD_01(config)#spanning-tree vlan 1 priority 8192
POD_01(config)#end

Vérification

Afficher la configuration STP du switch :

cisco#show spanning-tree bridge

POD_01#show spanning-tree bridge
                                                   Hello  Max  Fwd
Vlan                         Bridge ID              Time  Age  Dly  Protocol
---------------- --------------------------------- -----  ---  ---  --------
VLAN0001          8193 ( 8192,   1) 0016.46b7.d380    2    20   15  rstp   # Configuration priorité ok
VLAN0010         32778 (32768,  10) 0016.46b7.d380    2    20   15  rstp

Pour rappel la priorité = valeur de priorité  + numéro du VLAN (8192 + 1)

Activer le Portfast sur les interfaces

Par défaut, quand vous connectez un PC sur un switch sur lequel le STP est activé, il faut environ 30 secondes pour que le port auquel est connecté le PC permettre l’accès au réseau.

Les 30 secondes représentent le temps nécessaire au port pour transiter entre différents états (listening, learning, forwarding) pour valider qu’il n’y ait aucune boucle réseau.

La fonctionnalité portfast va désactiver le spanning-tree sur le port sur lequel elle est activée.

Configurer

Activer le portfast sur une interface :

cisco(config-if)#spanning-tree portfast

Exemple

POD_01#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
POD_01(config)#interface fastEthernet 1/0/23
POD_01(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION
%Portfast has been configured on FastEthernet1/0/23 but will only
 have effect when the interface is in a non-trunking mode.
POD_01(config-if)#end

Vérification

Afficher l’état du portfast sur une interface :

cisco#show spanning-tree interface type_interface nb_interface portfast

POD_01#show spanning-tree interface fastEthernet 1/0/23 portfast
VLAN0001            enabled   # Activation du portfast ok
POD_01#

– Fin du tutoriel –

Cisco

Switch Cisco – Configuration LLDP & CDP

Configuration d’un Port-Channel

À savoir

Link Layer Discovery Protocol (LLDP) est un protocole standardisé (IEEE 802.1AB) utilisé dans la découverte des topologies réseau et l’échange de configuration et des capacités des périphériques d’équipements directement connectés.
Il permet de d’effectuer un inventaire précis de la topologie physique et des équipements pour simplifier la gestion et la maintenance.
Cisco Discovery Protocol (CDP) est un protocole propriétaire de Cisco et rempli la même fonction que le LLDP. Ce protocole est utilisé par des équipements Cisco et quelques autres constructeurs (ex : VMware).
Dans un objectif d’interopérabilité, on utilisera le protocole LLDP dans un réseau composé d’équipements de constructeurs différents (ex : cisco + alcatel).

Configuration

Le protocole LLDP ou CDP doit être activé sur chaque switch pour que l’échange d’informations soit opérationnel.
Activer le protocole :

cisco(config)#{ lldp | cdp } run

Le protocole CDP est activé par défaut sur les switches Cisco, sur toutes les interfaces.
Configurer la fréquence (en secondes) de transmission des informations :

cisco(config)#{ lldp | cdp } timer secondes

Configurer le temps (en secondes) de validité des informations :

cisco(config)#{ lldp | cdp } holdtime secondes

Le holdtime représente le temps qu’un voisin va conserver dans sa table les informations au sujet de l’équipement adjacent. Le holdtime doit être supérieur au timer pour que le voisin reçoive les paquets LLDP/CDP avant la fin du holdtime. A la réception des paquets CDP/LLDP, le holdtime est réinitialisé.
Désactiver le lldp/cdp sur une ou plusieurs interfaces spécifiques :

cisco(config)#interface [ range ] type_interface interface(s)
cisco(config-if-range)#no cdp enable
cisco(config-if-range)#no lldp transmit

De préférence, on désactivera le lldp et cdp sur les interfaces sur lesquels sont connectés les clients, pour des raisons de sécurité.

Exemple de configuration

POD_1(config)#lldp run
POD_1(config)#lldp timer 30
POD_1(config)#lldp holdtime 60
POD_1(config)#
POD_1(config)#cdp timer 30
POD_1(config)#cdp holdtime 60
POD_1(config)#
POD_1(config)#interface range gigabitEthernet 0/2-24
POD_1(config-if-range)#no cdp enable
POD_1(config-if-range)#no lldp transmit
POD_1(config-if-range)#no lldp receive

Validation de la configuration

Afficher les informations l’état du LLDP/CDP :

cisco#show { lldp | cdp }

POD_1#show lldp
Global LLDP Information:
    Status: ACTIVE                                # Activation lldp ok
    LLDP advertisements are sent every 30 seconds # Timer ok
    LLDP hold time advertised is 60 seconds       # Holdtime ok
    LLDP interface reinitialisation delay is 2 seconds
POD_1#
POD_1#show cdp
Global CDP information:
        Sending CDP packets every 30 seconds     # Timer 30s ok
        Sending a holdtime value of 60 seconds   # Holdtime 60s ok
        Sending CDPv2 advertisements is  enabled # Activation CDP ok

Afficher l’état du LLDP/CDP sur les interfaces :

cisco#show { lldp | cdp } interface

POD_1#show lldp interface     # Affiche toutes les interfaces et leur état
GigabitEthernet0/1:
    Tx: enabled     # Activation transmission paquets LLDP ok
    Rx: enabled     # Activation réception paquets LLDP ok
    Tx state: IDLE
    Rx state: WAIT FOR FRAME
GigabitEthernet0/2:
    Tx: disabled     # Désactivation transmission paquets LLDP ok
    Rx: disabled     # Désactivation réception paquets LLDP ok
    Tx state: INIT
    Rx state: WAIT PORT OPER
(...)
POD_1#
POD_1#show cdp interface     # Affiche seulement les interfaces avec cdp activée
GigabitEthernet0/1 is up, line protocol is up     # Activation CDP ok
  Encapsulation ARPA
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds
(...)
 cdp enabled interfaces : 8
 interfaces up          : 2
 interfaces down        : 6

Afficher la liste des voisins et le type de matériel :

cisco#show { lldp | cdp } neighbors

POD_1#show lldp neighbors
Capability codes:
    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other
Device ID           Local Intf     Hold-time  Capability      Port ID
POD_2               Gi0/1          120        B               Gi0/1
Total entries displayed: 1
POD_1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
POD_2            Gig 0/1           152              S I   WS-C3560X Gig 0/1

Total cdp entries displayed : 1

Afficher les informations sur le trafic :

cisco#show { lldp | cdp } traffic

POD_1#show lldp traffic
LLDP traffic statistics:
    Total frames out: 238    # Transmission de paquets ok
    Total entries aged: 0
    Total frames in: 119     # Réception de paquets ok
    Total frames received in error: 0
    Total frames discarded: 0
    Total TLVs discarded: 0
    Total TLVs unrecognized: 0
POD_1#show cdp traffic
CDP counters :
        Total packets output: 117, Input: 30 # Transmission et réception de paquets ok
        Hdr syntax: 0, Chksum error: 0, Encaps failed: 0
        No memory: 0, Invalid packet: 0,
        CDP version 1 advertisements output: 0, Input: 0
        CDP version 2 advertisements output: 117, Input: 30

Afficher les informations détaillées sur un ou plusieurs voisins :

cisco#show { lldp | cdp } entry { nom_voisin | * }

POD_1#show lldp entry *
Capability codes:
    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other
------------------------------------------------
Local Intf: Gi0/1
Chassis id: 3c08.f69f.0000
Port id: Gi0/1
Port Description: CONNECT TO POD_1
System Name: POD_2
System Description:
Cisco IOS Software, C3560E Software (C3560E-UNIVERSALK9-M), Version 15.2(4)E5, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2017 by Cisco Systems, Inc.
Compiled Mon 18-Sep-17 11:41 by prod_rel_team
(...)
POD_1#
POD_1#show cdp entry POD_2
-------------------------
Device ID: POD_2
Entry address(es):
  IP address: 192.168.0.246
Platform: cisco WS-C3560X-24,  Capabilities: Switch IGMP
Interface: GigabitEthernet0/1,  Port ID (outgoing port): GigabitEthernet0/1
Holdtime : 152 sec
(...)
Cisco

Switch Cisco – Configuration Port-Channel

Configuration d’un Port-Channel

A savoir

Vous pouvez consulter le pense-bête sur la norme 802.3ad avant de débuter ce tutoriel.
Cisco a la particularité de posséder son propre protocole propriétaire PAgP (Port Aggregation Protocol) pour les LAG et qui est similaire au protocole LACP. Celui-ci ne suit pas la norme 802.3ad mais la technologie EtherChannel de Cisco.
Voici les différences notables entre la technologie EtherChannel et 802.3ad :

EtherChannel IEEE 802.3ad Link Aggregation
Nécessite une configuration du switch Nécessite une configuration du switch pour l’échange de LACPDU
Les switches ne s’échange pas de paquets Des LACPDU sont échangées à une intervalle régulière pour contrôler l’état des liens physiques

Les équipements d’autres constructeurs ne supportent pas le protocole PAgP et celui-ci sera utilisé seulement pour connecter des switches Cisco (si vous le souhaitez).

Configuration

Chaque switch doit être configuré pour que le LAG fonctionne.

Interfaces physiques

Sélectionner les interfaces à grouper dans un LAG :

cisco(config)#interface range type_interface interfaces

Ajouter les interfaces au groupe du port-channel :

cisco(config-if-range)#channel-group numéro_groupe mode mode

Compatibilités des modes LACP :

Active Passive
Active Oui Oui
Passive Oui Non

Le mode Active sur chaque switch est recommandé.
Compatibilités des modes PAgP :

Auto Desirable
Auto Oui Oui
Desirable Oui Non

Le mode Auto est l’équivalent du mode Active et le mode Desirable celui du mode Passive.
Il existe un autre mode, qui est le mode On. Celui-ci force la création d’un LAG sans utiliser de protocole de négociation au préalable comme PAgP ou LACP. Pour que le LAG soit fonctionnel, les 2 switches doivent être en mode On.

Interface du Port-Channel

Passer en mode configuration d’un port-channel :

cisco(config)#interface port-channel numéro_channel

L’interface du port-channel se configure comme une interface physique. Généralement, le LAG entre 2 switches est utilisé par plusieurs vLAN’s et est donc en mode trunk.
Vous pouvez suivre le tutoriel sur l’association une interface à un vLAN pour configurer votre interface.
Attention : normalement la configuration que vous appliquez sur l’interface du port-channel est répliquée sur les interfaces physiques (faite un show running-config pour vérifier). Si ce n’est pas cas, vous devez les configurer séparément, c’est à dire que si vous activez le mode trunk sur le port-channel par exemple, vous devez aller le faire sur les interfaces physiques qui le composent.

Exemple de configuration

Protocole LACP

Switch 1 :

cisco(config)#interface range gigabitethernet 0/1-2
cisco(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1
cisco(config-if-range)#interface port-channel 1
cisco(config-if)#description INTER SWITCH
cisco(config-if)#switchport trunk encapsulation dot1q
cisco(config-if)#switchport mode trunk

Switch 2 :

cisco(config)#interface range gigabitethernet 0/1-2
cisco(config-if-range)#channel-group 1 mode passive
Creating a port-channel interface Port-channel 1
cisco(config-if-range)#interface port-channel 1
cisco(config-if)#description INTER SWITCH
cisco(config-if)#switchport trunk encapsulation dot1q
cisco(config-if)#switchport mode trunk

 Protocole PAgP

Switch 1 :

POD_1(config)#interface range gigabitethernet 0/1-2
POD_1(config-if-range)#channel-group 1 mode auto
Creating a port-channel interface Port-channel 1
POD_1(config-if-range)#interface port-channel 1
POD_1(config-if)#description INTER SWITCH
POD_1(config-if)#switchport trunk encapsulation dot1q
POD_1(config-if)#switchport mode trunk

Switch 2 :

POD_2(config)#interface range gigabitethernet 0/1-2
POD_2(config-if-range)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
POD_2(config-if-range)#interface port-channel 1
POD_2(config-if)#description INTER SWITCH
POD_2(config-if)#switchport trunk encapsulation dot1q
POD_2(config-if)#switchport mode trunk

Validation de la configuration

Afficher le résumé des configurations des port-channel :

cisco#show etherchannel summary

POD_1# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
(...)
# LACP :
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)     # PC ok
# PAgP :

Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Gi0/1(P)    Gi0/2(P)     # PC ok

Afficher le statut de l’interface du port-channel :

cisco#show interfaces port-channel numéro_interface

POD_1#show interfaces port-channel 1
Port-channel1 is up, line protocol is up (connected)   # PC up et protocole ok
  Hardware is EtherChannel, address is 3c08.f69f.0681 (bia 3c08.f69f.0681)
  Description: LAG SWITCH
  MTU 9000 bytes, BW 2000000 Kbit/sec, DLY 10 usec,    # Bande passante ok
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
(...)

Afficher les informations sur le LACP ou PAgP :

cisco#show { lacp | pagp } internal

POD_1#show lacp internal
Flags:  S - Device is requesting Slow LACPDUs
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode
Channel group 1
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi0/1     SA      bndl      32768         0x1       0x1     0x102       0x3D
Gi0/2     SA      bndl      32768         0x1       0x1     0x103       0x3D
# Ou bien
POD_1#show pagp internal
Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        d - PAgP is down
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.
Channel group 1
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Gi0/1     SAC   U6/S7   HQ      30s      1        128        Any      5001
Gi0/2     SAC   U6/S7   HQ      30s      1        128        Any      5001

Afficher les informations sur le LACP du voisin :

cisco#show { lacp | pagp } numéro_channel neighbor

POD_1#show lacp 1 neighbor
Flags:  S - Device is requesting Slow LACPDUs
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode
Channel group 1 neighbors
Partner's information:
                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi0/1     SP      32768     3c08.f69f.0000  24s    0x0    0x1    0x102   0x3C
Gi0/2     SP      32768     3c08.f69f.0000   9s    0x0    0x1    0x103   0x3C
# Ou bien
POD_1#show pagp 1 neighbor
Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
Channel group 1 neighbors
          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Gi0/1     POD_2                3c08.f69f.0000   Gi0/1        7s SC      10001
Gi0/2     POD_2                3c08.f69f.0000   Gi0/2       23s SC      10001

Afficher les informations sur le nombre de paquets échangés :

cisco#show { lacp | pagp } counters

POD_1#show lacp counters
             LACPDUs         Marker      Marker Response    LACPDUs
Port       Sent   Recv     Sent   Recv     Sent   Recv      Pkts Err
---------------------------------------------------------------------
Channel group: 1
Gi0/1       10     6        0      0        0      0         0     # Négociation Ok
Gi0/2       8      5        0      0        0      0         0
# Ou bien
POD_1#show pagp counters
          Information         Flush        PAgP
Port      Sent    Recv     Sent    Recv    Err Pkts
---------------------------------------------------
Channel group: 1
Gi0/1     31      31       0       0       0     # Négociation Ok
Gi0/2     30      31       0       0       0

Cisco

Switch Cisco – Association vLAN & Interface

Mode configuration spécifique

Passer en mode configuration interface :

cisco(config)#interface type_interface numéro_interface
cisco(config-if)#

Pour obtenir la liste des types interfaces :

cisco(config)#interface ?

Ce sera surtout les types FastEthernet et GigabitEthernet qui nous intéresseront.
En fonction du switch, le numéro d’interface sera au format :

    • x/x ⇒ 0/24
    • x/x/x ⇒ 1/0/24

Configurer plusieurs interfaces à la fois :

cisco(config)#interface range { fastethernet | gigabitethernet } x/x-X | x/x/x-X
cisco(config-if-range)#

Assigner un seul vLAN à une interface

Configuration

Activer le mode access :

cisco(config-if)#switchport mode access

Le mode access permet d’ajouter une interface dans un seul vLAN.
Associer l’interface à un vLAN :

cisco(config-if)#switchport access vlan vlan_id

Exemple de configuration

POD_1(config)#interface range gigabitEthernet 0/1-12
POD_1(config-if-range)#switchport mode access
POD_1(config-if-range)#switchport access vlan 10

Validation de la configuration

Afficher la liste des vLAN’s :

cisco#show vlan

POD_1#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/13, Gi0/14, Gi0/15, Gi0/16
                                                Gi0/17, Gi0/18, Gi0/19, Gi0/20
                                                Gi0/21, Gi0/22, Gi0/23, Gi0/24
10   TUTOFACILE                       active    Gi0/1, Gi0/2, Gi0/3, Gi0/4     # Ajout interfaces ok
                                                Gi0/5, Gi0/6, Gi0/7, Gi0/8
                                                Gi0/9, Gi0/10, Gi0/11, Gi0/12
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Assigner plusieurs vLAN’s à une interface (trunk)

Voici un tableau de résultats en fonction du mode configuré sur chaque extrémité du lien 802.1q :
Image1

Configuration

Activer l’encapsulation dot1q (utilisation de la norme 802.1q) :

cisco(config-if)#switchport trunk encapsulation dot1q

Activer le mode trunk :

cisco(config-if)#switchport mode trunk

Le mode trunk permet d’ajouter une interface dans plusieurs vLAN’s. Une interface configurée en mode trunk uniquement, sera associée à tous les vLAN’s (1 à 4094).
Assigner des vLAN’s spécifiques à l’interface :

cisco(config-if)#switchport trunk allowed vlan vlan_id,vlan_id,vlan_id,(…)

Comme expliqué dans le pense-bête sur la norme 802.1q, le switch tag les trames pour permettre la détermination de son appartenance. Néanmoins, tout le trafic réseau ne supporte pas le « tagging ».
Pour cette raison, il est possible de configurer un vLAN natif par lequel passera tout le trafic untagged.
Configurer un vLAN natif :

cisco(config-if)#switchport trunk native vlan vlan_id

Exemple de configuration

POD_1(config)#interface gigabitEthernet 0/1
POD_1(config-if)#switchport trunk encapsulation dot1q
POD_1(config-if)#switchport mode trunk
POD_1(config-if)#switchport trunk allowed vlan 10
POD_1(config-if)#switchport trunk native vlan 1

Validation de la configuration

Afficher la liste des interfaces en mode trunk

cisco#show interface trunk

POD_1#show interfaces trunk
Port        Mode             Encapsulation  Status        Native vlan
Gi0/1       on               802.1q         trunking      1     # Activation mode trunk + vlan natif ok
Port        Vlans allowed on trunk
Gi0/1       10     # vLAN spécifique au trunk ok
Port        Vlans allowed and active in management domain
Gi0/1       10
Port        Vlans in spanning tree forwarding state and not pruned
Gi0/1       10

 

Cisco

Swicth Cisco – Création & Configuration vLAN

Créer un vLAN

Avant de suivre ce tutoriel, vous pouvez lire le pense-bête sur le vLAN ici.

Configuration

Créer un vLAN :

cisco(config)#vlan vlan_id
cisco(config-vlan)#

vlan_id = Numéro de vLAN compris entre 1 et 4094 (4095 & 4096 sont reservés)
Créer plusieurs vLAN à la fois :

cisco(config)#vlan vlan_id,vlan_id,vlan_id,(…)
cisco(config-vlan)#

Chaque vlan id doit être séparé par une virgule.
Donner un nom au vLAN :

cisco(config-vlan)#name « nom_vlan« 

Vous ne pouvez pas définir de nom si vous créez plusieurs vLAN’s à la fois.

Exemple de configuration

POD_1(config)#vlan 10
POD_1(config-vlan)#name « tutofacile« 

Validation de la configuration

Afficher la liste des vLAN’s :

cisco#show vlan

POD_1#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/1, Gi0/2, Gi0/3, Gi0/4
                                                Gi0/5, Gi0/6, Gi0/7, Gi0/8
                                                Gi0/9, Gi0/10, Gi0/11, Gi0/12
                                                Gi0/13, Gi0/14, Gi0/15, Gi0/16
                                                Gi0/17, Gi0/18, Gi0/19, Gi0/20
                                                Gi0/21, Gi0/22, Gi0/23, Gi0/24
10   "tutofacile"                     active     # Création vlan ok
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
(...)

Créer l’interface virtuelle du vLAN

Comme expliqué dans le pense-bête sur les vLAN’s, la communication entre vLAN’s se fait via un routeur.
Pour ce faire, le vLAN doit posséder une interface qui servira de passerelle. Cette interface est une interface virtuelle, aussi appelée Switch Virtual Interface (SVI). Chaque vLAN peut être lié à une seule SVI. La SVI peut également servir pour bien d’autres choses (à voir dans d’autres tutoriels).

Configuration

Créer l’interface du vLAN :

cisco(config)#interface vlan vlan_id
cisco(config-if)#

Renseigner une description :

cisco(config-if)#description description

Les guillemets ne sont pas nécessaires pour la description.
Configurer une adresse IP :

# Adresse IP fixe
cisco(config-if)#ip address adresse_ip adresse_masque
# Adresse IP par DHCP
cisco(config-if)#ip address dhcp

Activer l’interface :

cisco(config-if)#no shutdown

Exemple de configuration

POD_1(config)#interface vlan 10
POD_1(config-if)#description RESEAU TUTOFACILE
POD_1(config-if)#ip address 192.168.10.254 255.255.255.0
POD_1(config-if)#no shutdown

Validation de la configuration

Afficher la configuration de l’interface :

cisco#show interface vlan vlan_id

POD_1#show interfaces vlan 10              # Création interface ok (car la commande fonctionne)
Vlan10 is up, line protocol is down        # Activation du vLAN ok
  Hardware is EtherSVI, address is 3c08.f69f.06c1 (bia 3c08.f69f.06c1)
  Description: RESEAU TUTOFACILE           # Description ok
  Internet address is 192.168.10.254/24    # Configuration IP ok
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
(...)

Affichage plus général :

# Afficher le statue et la description de toutes les interfaces
cisco#show interfaces description
# Afficher la configuration IP de toutes les interfaces
cisco#show ip interfaces brief

POD_1#show interfaces description
Interface                      Status         Protocol Description
Vl1                            admin down     down
Vl10                           up             down     RESEAU TUTOFACILE
Fa0                            up             up
Gi0/1                          admin down     down     CONNECT TO POD_2
Gi0/2                          admin down     down     CONNECT TO POD_2
POD_1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES NVRAM  administratively down down
Vlan10                 192.168.10.254  YES manual up                    down
FastEthernet0          192.168.0.247   YES DHCP   up                    up
GigabitEthernet0/1     unassigned      YES unset  administratively down down
GigabitEthernet0/2     unassigned      YES unset  administratively down down

La méthode manual (affichée à la seconde commande) signifie que l’adresse IP a été configurée manuellement. Si l’adresse est fournie par DHCP, alors la méthode sera dhcp.


Pour aller plus loin : Switch Cisco – Association vLAN & Interface